3 thoughts to “Installing ffmpeg 0.9 on debian squeeze and newer”

  1. Hi,
    I am trying to follow your guide but I hit a wall with installing -dev packages :/ , what I get:
    […]
    The following packages have unmet dependencies:
    libaacplus-dev : Depends: libaacplus2 (= 2.0.2-0.3) but it is not going to be installed
    libfaac-dev : Depends: libfaac0 (= 1:1.28-0.8) but it is not going to be installed
    libmp3lame-dev : Depends: libmp3lame0 (= 1:3.99.5-0.0) but it is not going to be installed
    libx264-dev : Depends: libx264-122 (= 3:0.122.2184+git5c85e0a-0.0) but it is not going to be installed
    libxvidcore-dev : Depends: libxvidcore4 (= 3:1.3.2-0.4) but it is not going to be installed
    E: Broken packages

    So my next was to install them but, again… I hit a wall :( :
    saper@debian-a64:~$ sudo apt-get -f install libaacplus2 libfaac0 libmp3lame0 libx264-122 libxvidcore4
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libaacplus2 : PreDepends: multiarch-support but it is not installable
    libfaac0 : PreDepends: multiarch-support but it is not installable
    libmp3lame0 : PreDepends: multiarch-support but it is not installable
    libx264-122 : PreDepends: multiarch-support but it is not installable
    libxvidcore4 : PreDepends: multiarch-support but it is not installable
    E: Broken packages

    I tried digging in google for “multiarch-support” but no luck… Can you help?

  2. I forgot to add:

    saper@debian-a64:~$ uname -a
    Linux debian-a64 2.6.32-5-amd64 #1 SMP Thu Mar 22 17:26:33 UTC 2012 x86_64 GNU/Linux

    saper@debian-a64:~$ arch
    x86_64

    saper@debian-a64:~$ cat /etc/debian_version
    6.0.4

Leave a Reply

Your email address will not be published.

*